OBIEE Online Training

Wednesday, June 8, 2011

LDAP Configuration in obiee11g

for more clear steps in this context.
http://download.oracle.com/docs/cd/E14571_01/bi.1111/e10543/sso.htm#CEGJJFED

http://download.oracle.com/docs/cd/E21764_01/bi.1111/e10543/toc.htm.

SSO can be implemented in OBIEE 11g by steps like

1. Configure the SSO authentication provider.
2. Configure HTTP proxy.
etc

1 comment:

  1. Hi - We are trying to set up SSO - EBS for OBIEE 11g,

    We have been trying to integrate EBS with OBIEE with EBS-ICX Cookie mechanism- Somehow we couldn’t able to achieve this functionality - Need help **URGENT**

    Platform: Linux - BI APPS 7.9.6.3 & OBIEE 11.1.1.5.0 & EBS R12

    Below are the steps:

    1. On the Connection Scripts tab, we have: call /* valueof(NQ_SESSION.ACF) */ APP_SESSION.validate_icx_session(‘valueof(NQ_SESSION.ICX_SESSION_COOKIE)’)

    2. Initialization Block EBS Security Context - In Data Source default Initalization string : we have
    SELECT FND_GLOBAL.RESP_ID, FND_GLOBAL.RESP_APPL_ID, FND_GLOBAL.SECURITY_GROUP_ID, FND_GLOBAL.RESP_NAME, FND_GLOBAL.USER_ID, FND_GLOBAL.EMPLOYEE_ID, FND_GLOBAL.USER_NAME FROM DUAL

    3. In Edit Data Target Section - we have following session variables
    EBS_RESP_ID
    EBS_RESP_APPL_ID
    EBS_SEC_GROUP_ID
    EBS_RESP_NAME
    EBS_USER_ID
    EBS_EMPLOYEE_ID
    USER

    4. authenticationschemas.xml:



    5. instanceconfig.xml:
    UidPwd,Impersonate,UidPwd-soap,Impersonate-soap,EBS-ICX

    6. Restrated the BI Server. And trying to login from EBS but Cannot login to OBIEE....

    Testing:

    1. Yes - Our E-Business Suite and OBIEE are on the same domain
    2. Yes - E-Business Suite and OBIEE are both using the same security protocol (Both using http)
    3. call app_session.validate_icx_session('Actual Cookie Value');
    Result: Call completed
    4. select fnd_global.user_name from dual;
    Result: Output is my user which has OBIEE Responsibility and created in EBS

    Do we still need to configure any additional things in Enterprise Manager and Weblogic Server? Am I missing anything Here Please let me know ASAP

    Log:
    [nQSError: 13011] Query for Initialization Block 'EBS Security Context' has failed

    ReplyDelete